[CocoaPods报错] Failed to connect to GitHub to update the CocoaPods/Specs specs repo - Please check if you are offline, or that GitHub is down

问题描述

使用pod update或者pod repo update时,出现了如下错误

Failed to connect to GitHub to update the CocoaPods/Specs specs repo - Please check if you are offline, or that GitHub is down

一看以为是网络问题,经过检查后不是,原因是2018年2月后,弱密码标准被删除

Read more   2020/3/5 posted in  BUG记录

CocoaPods安装错误 RPC failed; curl 56 LibreSSL SSL_read: SSL_ERROR_SYSCALL, errno 60

问题描述

执行pod update --no-repo-update时提示如下错误

Installing SPAlert 2.1.1 (was 1.0.2)

[!] Error installing SPAlert
[!] /usr/bin/git clone https://github.com/IvanVorobei/SPAlert.git /var/folders/zx/ggz348td2gzck1vdqgh6bvfr0000gn/T/d20200228-27956-10msht5 --template= --single-branch --depth 1 --branch 2.1.1

Cloning into '/var/folders/zx/ggz348td2gzck1vdqgh6bvfr0000gn/T/d20200228-27956-10msht5'...
error: RPC failed; curl 56 LibreSSL SSL_read: SSL_ERROR_SYSCALL, errno 60
fatal: the remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed
Read more   2020/2/28 posted in  BUG记录

xcodebuild: error: SWIFT_VERSION '3.0' is unsupported, supported versions are: 4.0, 4.2, 5.0.

问题描述

最近重构了一下自己写的LJTool这个库,在使用CocoPods 发布时遇到这个问题,执行pod lib lint LJTool.podspec提示如下错误

- NOTE  | xcodebuild:  error: SWIFT_VERSION '3.0' is unsupported, supported versions are: 4.0, 4.2, 5.0. (in target 'LJTool' from project 'Pods')
Read more   2020/2/28 posted in  BUG记录

library not found for -libstdc++.6.0.9

原因

升级到XCode10后,由于去掉陈旧的libstdc++库替换为libc++,-libstdc++.6.0.9就被删除了

Read more   2020/2/12 posted in  BUG记录